你现在使用IE浏览器/旧版edge浏览器访问财富池指标公式网,为了保证你正常使用本网站所有功能,请使用其他浏览器或更新edge浏览器

取消提醒
收藏财富池指标公式网
当前位置: 财富池首页 圈子首页 翔博软件 免费分享 【翔博软件指标】黄金分割线 自用纯K(通达信公式 主图 源码 测试图)

翔博软件

成员:29人 帖子:118

翔博软件

圈主


帖子:96

动态:11

获赞:876

评论:0

【翔博软件指标】黄金分割线 自用纯K(通达信公式 主图 源码 测试图)

2022年12月02日 18:45 翔博软件 1,468
收藏
{黄金分割线}{自用纯K}N:=34;高1:=REF(HHV(H,N),3);低1:=REF(LLV(L,N),3);H1:=高1-(高1-低1)*0.191;H2:=高1-(高1-低1)*0.382;H3:=高1-(高1-低1)*0.500;H4:=高1-(高1-低1)

{黄金分割线}

{自用纯K}
N:=34;
高1:=REF(HHV(H,N),3);
低1:=REF(LLV(L,N),3);
H1:=高1-(高1-低1)*0.191;
H2:=高1-(高1-低1)*0.382;
H3:=高1-(高1-低1)*0.500;
H4:=高1-(高1-低1)*0.618;
H5:=高1-(高1-低1)*0.809;
顶:REFDATE(高1,DATE),COLORRED,DOTLINE;
一:REFDATE(H1,DATE),COLORGRAY,DOTLINE;
二:REFDATE(H2,DATE),COLORGRAY,DOTLINE;
三:REFDATE(H3,DATE),COLORRED,DOTLINE;
四:REFDATE(H4,DATE),COLORGRAY,DOTLINE;
五:REFDATE(H5,DATE),COLORGRAY,DOTLINE;
低:REFDATE(低1,DATE),COLORGREEN,DOTLINE;
TT4:=(CURRBARSCOUNT=34);
DRAWTEXT(TT4 AND 顶,顶,'---顶---'),COLORCYAN;
DRAWTEXT(TT4 AND 一,一,'-0.809-'),COLORCYAN;
DRAWTEXT(TT4 AND 二,二,'-0.618-'),COLORCYAN;
DRAWTEXT(TT4 AND 三,三,'-0.500-'),COLORCYAN;
DRAWTEXT(TT4 AND 四,四,'-0.382-'),COLORCYAN;
DRAWTEXT(TT4 AND 五,五,'-0.191-'),COLORCYAN;
DRAWTEXT(TT4 AND 低,低,'---底---'),COLORCYAN;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
DRAWTEXT(CURRBARSCOUNT=1,顶,CON2STR(顶,2)),COLORMAGENTA;
DRAWTEXT(CURRBARSCOUNT=1,一,CON2STR(一,2)),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=1,二,CON2STR(二,2)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,三,CON2STR(三,2)),COLORYELLOW;
DRAWTEXT(CURRBARSCOUNT=1,四,CON2STR(四,2)),COLORGREEN;
DRAWTEXT(CURRBARSCOUNT=1,五,CON2STR(五,2)),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=1,低,CON2STR(低,2)),COLORMAGENTA;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
{K线------------------------------------------------绿} 
STICKLINE(CLOSE<=REF(C,1),CLOSE,OPEN,0.1,0),COLOR00CC00; 
STICKLINE(CLOSE<=REF(C,1),CLOSE,OPEN,3.1,0),COLOR00CC00;
STICKLINE(CLOSE<=REF(C,1),CLOSE,OPEN,2.7,0),COLOR003300;
STICKLINE(CLOSE<=REF(C,1),CLOSE,OPEN,2.1,0),COLOR006600;
STICKLINE(CLOSE<=REF(C,1),CLOSE,OPEN,1.5,0),COLOR009900;
STICKLINE(CLOSE<=REF(C,1),CLOSE,OPEN,0.9,0),COLOR00CC00;
STICKLINE(CLOSE<=REF(C,1),CLOSE,OPEN,0.3,0),COLOR00FF00;
{K线------------------------------------------------红}
STICKLINE(CLOSE>REF(C,1),CLOSE,OPEN,0.1,0),COLOR0000FF; 
STICKLINE(CLOSE>REF(C,1),CLOSE,OPEN,3.1,0),COLOR0000FF;
STICKLINE(CLOSE>REF(C,1),CLOSE,OPEN,2.7,0),COLOR000077; 
STICKLINE(CLOSE>REF(C,1),CLOSE,OPEN,2.1,0),COLOR000099; 
STICKLINE(CLOSE>REF(C,1),CLOSE,OPEN,1.5,0),COLOR0000BB;
STICKLINE(CLOSE>REF(C,1),CLOSE,OPEN,0.9,0),COLOR0000DD;
STICKLINE(CLOSE>REF(C,1),CLOSE,OPEN,0.3,0),COLOR0000FF;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
{涨跌停}
今涨停:ZTPRICE(REF(C,1),0.1),COLORRED,NODRAW; 
今跌停:DTPRICE(REF(C,1),0.1),COLOR00A600,NODRAW;
明涨停:ZTPRICE(C,0.1),COLORRED,NODRAW; {盘后挂单看};
明跌停:DTPRICE(C,0.1),COLOR00A600,NODRAW;{盘后挂单看};
{主题投资,主营业务}
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(1,0.00,0.00,0,'主题投资:'),COLORGREEN;
DRAWTEXT_FIX(1,0.06,0.00,0,EXTERNSTR(0,1)),COLORCYAN;
DRAWTEXT_FIX(1,0.00,0.035,0,'主营业务:'),COLORGREEN;
DRAWTEXT_FIX(1,0.06,0.035,0,EXTERNSTR(0,2)),COLORCYAN;
DRAWTEXT_FIX(ISLASTBAR,0.06,0.07,0,STRCAT(Z3,GNBLOCK)),COLORCYAN;
{涨_下跌_具体数据}
上涨家数:=STRCAT('【沪深上涨家数】:',CON2STR(DYNAINFO(60),0));
下跌家数:=STRCAT('【沪深下跌家数】:',CON2STR(DYNAINFO(61),0));
上涨百分比:=DYNAINFO(60)/(DYNAINFO(60)+DYNAINFO(61))*100;
下跌百分比:=DYNAINFO(61)/(DYNAINFO(60)+DYNAINFO(61))*100;
DRAWTEXT_FIX(1,0.0575,0.105,0,上涨家数),COLORRED;
DRAWTEXT_FIX(1,0.16,0.105,0,STRCAT(STRCAT('(',VAR2STR(上涨百分比,2)),'%)')),COLORRED;
DRAWTEXT_FIX(1,0.22,0.105,0,下跌家数),COLORGREEN;
DRAWTEXT_FIX(1,0.32,0.105,0,STRCAT(STRCAT('(',VAR2STR(下跌百分比,2)),'%)')),COLORGREEN;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
{右上角年月日}
TA0:=YEAR AND MONTH AND DAY;
TA1:=STRCAT(CON2STR(YEAR,0),'年');
TA2:=STRCAT(CON2STR(MONTH,0),'月');
TA3:=STRCAT(CON2STR(DAY,0),'日');
TA4:=STRCAT('星期',IF(WEEKDAY=1,'一',IF(WEEKDAY=2,'二',IF(WEEKDAY=3,'三',IF(WEEKDAY=4,'四',IF(WEEKDAY=5,'五',IF(WEEKDAY=6,'六','日')))))));
TA5:=STRCAT(STRCAT(STRCAT(TA1,TA2),STRCAT(TA3,TA4)),'');
DRAWTEXT_FIX(TA0,0.37,0.105,0,TA5),COLORWHITE;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
时间:=VAR2STR(9.25,2);
DRAWTEXT_FIX(C>0,0.001,1,0,VARCAT('时间:',时间)),COLORMAGENTA;
DRAWTEXT_FIX(C>O,0.01,0.9,0,'公众号:翔博软件工作室'),COLOR556699; 
竞价成交金额:=VAR2STR(DYNAINFO(15),2);
DRAWTEXT_FIX(C>0,0.055,1,0,VARCAT('竞价成交金额:',竞价成交金额)),COLORMAGENTA;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
★★:=(SUM(EMA((CLOSE+LOW)/2,1)/3,3)),COLORWHITE,LINETHICK1;
☆☆:=(MA(CLOSE,3)+MA(CLOSE,6)+MA(CLOSE,9))/3,LINETHICK1,DOTLINE,COLORMAGENTA;
∑:=(6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/21,COLORGREEN,LINETHICK1;
◎:(6*L+5*REF(L,1)+4*REF(L,2)+3*REF(L,3)+2*REF(L,4)+1*REF(L,5))/21,COLORWHITE,LINETHICK1,DOTLINE;
☆:(3*H+2*REF(H,1)+1*REF(H,2))/6,COLORGREEN,LINETHICK1,DOTLINE;
★:=(3*L+2*REF(L,1)+1*REF(L,2))/6,COLORRED,LINETHICK1,DOTLINE;
◆:=MA(MA(C,5),3),COLORWHITE,LINETHICK1,DOTLINE;
DA:=(3*CLOSE+OPEN+LOW+HIGH)/6;
≌:=(20*DA+19*REF(DA,1)+18*REF(DA,2)+17*REF(DA,3)+16*REF(DA,4)+15*REF(DA,5)+14*REF(DA,6)
+13*REF(DA,7)+12*REF(DA,8)+11*REF(DA,9)+10*REF(DA,10)+9*REF(DA,11)+8*REF(DA,12)
+7*REF(DA,13)+6*REF(DA,14)+5*REF(DA,15)+4*REF(DA,16)+3*REF(DA,17)+2*REF(DA,18)+
REF(DA,20))/210,COLORCYAN,LINETHICK1;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
HK:=EMA(C,3),COLORMAGENTA;
№H:=MA(HK,6),COLORCYAN,LINETHICK1,NODRAW;
{深蓝色柱}
STICKLINE(C>№H AND №H>O AND C>O,C,O,2.7,0),COLORB20000;
STICKLINE(C>№H AND №H>O AND C>O,C,O,2.7,0),COLOREC0000;
STICKLINE(C>№H AND №H>O AND C>O,C,O,2.1,0),COLORFF4600;
STICKLINE(C>№H AND №H>O AND C>O,C,O,1.5,0),COLORFF6300;
STICKLINE(C>№H AND №H>O AND C>O,C,O,0.9,0),COLORFF8B00;
STICKLINE(C>№H AND №H>O AND C>O,C,O,0.3,0),COLORFFAB00;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
BK:=EMA(C,6),COLORMAGENTA;
⊙H:=MA(BK,3),COLORRED,LINETHICK1;
{黄色柱}
STICKLINE(C>⊙H AND ⊙H>O AND C>O,O,(O+C)/2,2.7,0),COLOR335555;
STICKLINE(C>⊙H AND ⊙H>O AND C>O,O,(O+C)/2,2.1,0),COLOR338888;
STICKLINE(C>⊙H AND ⊙H>O AND C>O,O,(O+C)/2,1.5,0),COLOR33AAAA;
STICKLINE(C>⊙H AND ⊙H>O AND C>O,O,(O+C)/2,0.9,0),COLOR33CCCC;
STICKLINE(C>⊙H AND ⊙H>O AND C>O,O,(O+C)/2,0,0),COLOR33EEEE;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
{白色柱}
STICKLINE(CROSS(⊙H,№H) AND C>O,C,O,2.7,0),COLOR555555;
STICKLINE(CROSS(⊙H,№H) AND C>O,C,O,2.7,0),COLOR777777;
STICKLINE(CROSS(⊙H,№H) AND C>O,C,O,2.1,0),COLOR999999;
STICKLINE(CROSS(⊙H,№H) AND C>O,C,O,1.5,0),COLORBBBBBB;
STICKLINE(CROSS(⊙H,№H) AND C>O,C,O,0.9,0),COLORDDDDDD;
STICKLINE(CROSS(⊙H,№H) AND C>O,C,O,0.3,0),COLORFFFFFF;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
№:MA(HK,6),COLORCYAN,LINETHICK1;
⊙:MA(BK,3),COLORRED,LINETHICK1;
{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓}
{涨_下跌_具体数据}
涨停:=(CLOSE/REF(C,1)>=1.09)AND C=H;
STICKLINE(涨停,CLOSE,OPEN,0.1,0),COLORYELLOW;
跌停:=(C/REF(C,1)<=0.91)AND C=L;
STICKLINE(跌停,CLOSE,OPEN,0.1,0),COLORWHITE;

{〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓〓};



过去一年多里,翔博软件研发的“指标”在财富池上热销,销售之火,令人振奋。


更重要的是如果你了解翔博软件,你就应该知道,我们专注于指标公式编写有10几年了。公式类型:主图公式 副图公式 选股公式 股票池 预警公式 分时公式等,是对技术分析一项激动人心的、价值不菲的充实。


技术投资的核心是什么?


这么多年来,我编写超过10w+指标公式,能沉淀下来的,其实并不多,因为,每一个我都会运用在实践中大量去测试.......然后不断的总结,变成可复制,可操作的系统。


毕竟谁都明白,在已经赚钱的地方追加投资是最简单、最快速、最安全的赚钱方法!



点击查阅 #经典指标和战法



找到一个好的老师,带你入门,安安心心练技术。 

你也可以随时随地赚钱,自由潇洒的生活!



PS:免费源码,限圈子内可见,现免费开放100个名额。希望有您能抓住此次机会。

PPS:我相信您一定会喜欢并且帮我宣传它的。这也就是我为您免费提供的原因。

9
举报
本圈子只作为个人的指标系统使用交流、信号分享,指标使用,学习心得记录的地方。 所有内容均不作为各位股友的操作参考依据,据此参考操作后果自负。

评论

同分类其他帖子