你现在使用IE浏览器/旧版edge浏览器访问财富池股票站,为了保证你正常使用本网站所有功能,请使用其他浏览器或更新edge浏览器

取消提醒
选股公式
  • 选股公式
  • 选股图形
  • 炒股高手
  • 炒股技巧
  • 炒股软件

请选择您需要的分类

当前位置: 财富池  >  选股公式  >  MACD、KDJ提前共振 可提前2到3天金叉和死叉 通达信指标公式副图 源码 贴图

VIP免费下载,不扣币 MACD、KDJ提前共振 可提前2到3天金叉和死叉 通达信指标公式副图 源码 贴图

发布时间:2021-09-16 14:34:06

浏览数:1.06W

收藏数:0

0财富币

成为VIP,免费下载该公式

下载必看 下载必看(为了保障您的权益,请在下载指标前务必点击右边按钮展开看清楚相关说明)

展开

指标公式介绍

财富池指标公式网(www.cfchi.com)提醒您:股市有风险,投资需谨慎。

指标特点: 完全开源 指标培训 独家限量 短线激进 中线稳健

源码属性: 不加密
公式类型: 副图公式
适用软件: 通达信
未来函数: 不包含
适合环境: 不限

指标公式描述

MACD、KDJ提前共振 可提前2到3天金叉和死叉 通达信指标公式副图 源码 贴图

指标简介:
把MACD的周期改了一下,提前2到3天金叉和死叉,可以提早判断。
自用指标,仅供参考

指标图示:






指标源码:

DIF:(EMA(CLOSE,6)-EMA(CLOSE,13))*100;
DEA:EMA(DIF,5);
MACD:(DIF-DEA)*2,COLORSTICK;
DRAWICON(CROSS(DIF,DEA),DEA,1);
DRAWICON(CROSS(DEA,DIF),DEA,2);
IF(DIF<DEA,DIF,DRAWNULL),COLORGREEN;
DD:=C=HHV(C,180);
EE:=DEA< REF(DEA,1) AND REF(DEA< REF(DEA,1),1)=1;
CC:=C> REF(C,1) AND REF(C> REF(C,1),1)=1;
顶背离:=(DD AND EE AND DEA< HHV(DEA,180))*DEA;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
{顶背:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);}
DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORBROWN,LINETHICK2;
RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*100;
K:SMA(RSV,9,3),COLORMAGENTA;
D:SMA(K,9,3),COLORBLUE;
J:3*K-2*D,COLORGRAY;
IF(J<D,J,DRAWNULL),COLORFFEE44;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
B1:=REF(C,A1+1)>C AND REF(DIF,A1+1)<DIF AND CROSS(DIF,DEA);
A22:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A22+1)>C AND REF("KDJ.K"(9,3,3),A22+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
DRAWTEXT(B1,DEA-0.20,'▲MACD底背'),COLORWHITE;
DRAWTEXT(B2,D-0.20,'●KDJ底背'),COLORYELLOW;
{DJ:=CROSS(J,D) AND D<20;
DRAWTEXT(DJ,J-0.3,'低金叉'),COLORMAGENTA;
MDJ:=CROSS(DIF,DEA) AND DEA<0;
DRAWTEXT(MDJ,DEA-0.3,'低金叉'),COLORRED;
DRAWTEXT(CROSS(DEA,DIF),DIF+0.3,'死叉'),COLORCYAN;
DRAWTEXT(CROSS(D,J),J+0.3,'死叉'),COLORGREEN;}
A:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);
DRAWICON(A,LOW*0.98,1);
B4:CROSS(DIF,DEA) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
DRAWTEXT(B4,L-0.20,'★金叉共振'),COLOR0099FF;
DRAWICON(CROSS(K,D),D,1);
DRAWICON(CROSS(D,K),D,2);
BA:=DEA>REF(DEA,1);
BB:=SUM(BA,5)>=4;
BC:=C<O;
BD:=SUM(BC,5)>=2;
BXG:FILTER(BB AND BD AND J>REF(J,1) AND REF(J,1)<REF(J,2),3);
STICKLINE(BXG,HHV(J,60),HHV(J,60)-20,1,0),COLORRED;
SS:=EMA(C,11);
LL:=(EMA(C,1)+EMA(C,2)+EMA(C,3)+EMA(C,5))/4;
{短:EMA(LL,2),COLORGREEN,LINETHICK2;}
{长:EMA(SS,2),COLORMAGENTA,LINETHICK2;}
AA:=(C-LLV(C,10))/(HHV(C,10)-LLV(C,10));
(CROSS(AA,0.05)-1);

更多精彩内容,请关注财富池订阅号

其他说明
1、下载本公式需要消耗财富币,请保证你的财富币充足哦! 去充值

2、如果您发现财富池网站有不足之处,请点击  建议反馈  谢谢!

3、如果您发现下载的公式有违规操作,请点击  举报投诉  谢谢!

4、平台禁止发布“非法荐股”等非法证券投资咨询活动信息,一旦发现,请立即进行  举报投诉  ,一旦核实,平台将严肃处理!
5、该指标公式由平台高手发布,仅供学习和研究使用,不得用于商业或者非法用途。本站对于提供下载的指标、软件、图书等不拥有任何权利,其版权归该下载资源的合法拥有者所有,如有侵犯您的版权,请查看《财富池的侵权处理流程》和点击 举报投诉联系平台,本站将于两个工作日内移除相关内容,同时要求用户在23小时内删除从本站下载的文件。
公式下载需要0财富币

下一篇: 9:32分抓涨停板,吃大肉。嘎嘎香。 通达信条件选股公式!

上一篇: 庄家吸筹(超准)信号 通达信简单实用的庄家吸筹指标公式 副图 图示

评论

(MACD、KDJ提前共振 可提前2到3天金叉和死叉 通达信指标公式副图 源码 贴图)
表情
图片

(您最多只能上传8张照片)

150

  • 公式评论(0)
  • 按时间

    按热度

指标来源

相信自己

 已认证

发布作品:

公式1592 文章1501 粉丝数225

该高手发布的其他公式

更多

同类指标公式

成为炒股高手

送财富币

觉得这个指标有用的话

就来参与使用心得分享

评论可获5~10财富币不等, 官方采纳 后还可获双倍金额奖励!

去评论