你现在使用IE浏览器/旧版edge浏览器访问财富池股票站,为了保证你正常使用本网站所有功能,请使用其他浏览器或更新edge浏览器

取消提醒
选股公式
  • 选股公式
  • 选股图形
  • 炒股高手
  • 炒股技巧
  • 炒股软件

请选择您需要的分类

当前位置: 财富池  >  选股公式  >  顶底背离集合同花顺指标公式副图无未来

VIP免费下载,不扣币 顶底背离集合同花顺指标公式副图无未来

发布时间:2021-10-08 19:31:39

浏览数:2,765

收藏数:1

0财富币

成为VIP,免费下载该公式

下载必看 下载必看(为了保障您的权益,请在下载指标前务必点击右边按钮展开看清楚相关说明)

展开

指标公式介绍

财富池指标公式网(www.cfchi.com)提醒您:股市有风险,投资需谨慎。

指标特点: 完全开源 指标培训 独家限量 短线激进 中线稳健

源码属性: 不加密
公式类型: 副图公式
适用软件: 同花顺
未来函数: 不包含
适合环境: 不限

指标公式描述

该公式为MACD、KDJ、RSI、DMI顶底背离的集合,在指标图中用文字显示背离情况,可为投资者的交易提供参考依据。


底:-50;
顶:50;
TR := SUM(MAX(MAX(HIGH-LOW,ABS(HIGH-REF(CLOSE,1))),ABS(LOW-REF(CLOSE,1))),14);
HD := HIGH-REF(HIGH,1);
LD := REF(LOW,1)-LOW;
PDM:= SUM(IF(HD>0 AND HD>LD,HD,0),14);
MDM:= SUM(IF(LD>0 AND LD>HD,LD,0),14);
PDI:= PDM*100/TR;
MDI:= MDM*100/TR;
A1:=BARSLAST(REF(CROSS("MACD.DIFF"(12,26,9),"MACD.DEA"(12,26,9)),1));
B1:=REF(C,A1+1)>C AND REF("MACD.DIFF"(12,26,9),A1+1)<"MACD.DIFF"(12,26,9) AND CROSS("MACD.DIFF"(12,26,9),"MACD.DEA"(12,26,9));
A2:=BARSLAST(REF(CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3)),1));
B2:=REF(C,A2+1)>C AND REF("KDJ.K"(9,3,3),A2+1)<"KDJ.K"(9,3,3) AND CROSS("KDJ.K"(9,3,3),"KDJ.D"(9,3,3));
A3:=BARSLAST(REF(CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24)),1));
B3:=REF(C,A3+1)>C AND REF("RSI.RSI1"(6,12,24),A3+1)<"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI1"(6,12,24),"RSI.RSI2"(6,12,24));
C1:=BARSLAST(REF(CROSS("MACD.DEA"(12,26,9),"MACD.DIFF"(12,26,9)),1));
D1:=REF(C,C1+1)<C AND REF("MACD.DIFF"(12,26,9),C1+1)>"MACD.DIFF"(12,26,9) AND CROSS("MACD.DEA"(12,26,9),"MACD.DIFF"(12,26,9));
C2:=BARSLAST(REF(CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3)),1));
D2:=REF(C,C2+1)<C AND REF("KDJ.K"(9,3,3),C2+1)>"KDJ.K"(9,3,3) AND CROSS("KDJ.D"(9,3,3),"KDJ.K"(9,3,3));
C3:=BARSLAST(REF(CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24)),1));
D3:=REF(C,C3+1)<C AND REF("RSI.RSI1"(6,12,24),C3+1)>"RSI.RSI1"(6,12,24) AND CROSS("RSI.RSI2"(6,12,24),"RSI.RSI1"(6,12,24));
C4:=BARSLAST(REF(CROSS(MDI,PDI),1));
D4:=REF(C,C+1)<C AND REF(MDI,C4+1)>MDI AND CROSS(MDI,PDI);
A4:=BARSLAST(REF(CROSS(PDI,MDI),1));
B4:=REF(C,A4+1)>C AND REF(PDI,A4+1)<PDI AND CROSS(PDI,MDI);
DMI底背:IF(B4>0,-50,0),COLOR0099FF,POINTDOT;
DRAWTEXT(DMI底背,-5,'DMI底背'),COLOR0099FF;
DMI顶背:IF(D4>0,50,0),COLORBLUE,POINTDOT;
DRAWTEXT(DMI顶背,15,'DMI顶背'),COLORBLUE;
MACD底背:IF(B1>0,-50,0),COLORRED,POINTDOT;
DRAWTEXT(MACD底背,-15,'MACD底背'),COLORRED;
KDJ底背:IF(B2>0,-50,0),COLORFF00FF,POINTDOT;
DRAWTEXT(KDJ底背,-25,'KDJ底背'),COLORFF00FF;
RSI底背:IF(B3>0,-50,0),COLORYELLOW,POINTDOT;
DRAWTEXT(RSI底背,-35,'RSI底背'),COLORYELLOW;
MACD顶背:IF(D1>0,50,0),COLOR00FF00,POINTDOT;
DRAWTEXT(MACD顶背,25,'MACD顶背'),COLOR00FF00;
KDJ顶背:IF(D2>0,50,0),COLORFFCC66,POINTDOT;
DRAWTEXT(KDJ顶背,35,'KDJ顶背'),COLORFFCC66;
RSI顶背:IF(D3>0,50,0),COLORFFFFFF,POINTDOT;
DRAWTEXT(RSI顶背,45,'RSI顶背'),COLORFFFFFF;
STICKLINE(B1>0,-50,0,2,0),COLORRED;
STICKLINE(B2>0,-50,0,2,0),COLORFF00FF;
STICKLINE(B3>0,-50,0,2,0),COLORYELLOW;
STICKLINE(D1>0,50,0,2,0),COLOR00FF00;
STICKLINE(D2>0,50,0,2,0),COLORFFCC66;
STICKLINE(D3>0,50,0,2,0),COLORWHITE;
STICKLINE(B4>0,-50,0,2,0),COLOR0099FF;
STICKLINE(D4>0,50,0,2,0),COLORBLUE;



更多精彩内容,请关注财富池订阅号

其他说明
1、下载本公式需要消耗财富币,请保证你的财富币充足哦! 去充值

2、如果您发现财富池网站有不足之处,请点击  建议反馈  谢谢!

3、如果您发现下载的公式有违规操作,请点击  举报投诉  谢谢!

4、平台禁止发布“非法荐股”等非法证券投资咨询活动信息,一旦发现,请立即进行  举报投诉  ,一旦核实,平台将严肃处理!
5、该指标公式由平台高手发布,仅供学习和研究使用,不得用于商业或者非法用途。本站对于提供下载的指标、软件、图书等不拥有任何权利,其版权归该下载资源的合法拥有者所有,如有侵犯您的版权,请查看《财富池的侵权处理流程》和点击 举报投诉联系平台,本站将于两个工作日内移除相关内容,同时要求用户在23小时内删除从本站下载的文件。
公式下载需要0财富币

下一篇: 精妙绝伦的无字天书主图指标公式超短线中的极品指标公式

上一篇: 判大势 做短势 通达信判大势定决策 版面

评论

(顶底背离集合同花顺指标公式副图无未来)
表情
图片

(您最多只能上传8张照片)

150

  • 公式评论(0)
  • 按时间

    按热度

指标来源

秦先生

 已认证

发布作品:

公式207 文章6 粉丝数69

该高手发布的其他公式

更多

同类指标公式

成为炒股高手

送财富币

觉得这个指标有用的话

就来参与使用心得分享

评论可获5~10财富币不等, 官方采纳 后还可获双倍金额奖励!

去评论