你现在使用IE浏览器/旧版edge浏览器访问财富池股票站,为了保证你正常使用本网站所有功能,请使用其他浏览器或更新edge浏览器

取消提醒

财富池网站简介

点击了解详情

 

财富池是一个为广大股民提供原创精品指标公式和炒股学习资源的分享平台。 


指标公式栏目: 

拥有海量、精选、实用、有效的指标,提供给用户多样化的选择;精品指标和推荐公式栏目更是针对性地满足用户精中求精的需求。 


炒股资源栏目: 

各类炒股学习资源免费提供,如技巧、课程、视频、软件和书籍,实时更新,掌握最新的炒股秘籍。 


财富池意在帮助股友们提升投资知识,培养正确的投资理念,少走弯路!欢迎您加入我们这个大家庭,共同学习成长,实现人生自我的价值! 

确定

|

仅此一次

取消
选股公式
  • 选股公式
  • 选股图形
  • 炒股高手
  • 炒股技巧
  • 炒股视频
  • 炒股课程
  • 炒股软件
  • 炒股书籍

请选择您需要的分类

当前位置: 财富池  >  选股公式  >  MACD+KDJ多重背离副图公式源码

VIP免费下载,不扣币 MACD+KDJ多重背离副图公式源码

发布时间:2018-06-28 09:25:36

浏览数:4.37W

收藏数:0

5财富币

成为VIP,免费下载该公式

下载必看(为了保障您的权益,请在下载指标前务必点击右边按钮展开看清楚相关说明)

展开

指标公式介绍

您当前浏览的公式是:MACD+KDJ多重背离副图公式源码

指标特点: 完全开源 指标培训 独家限量 短线激进 中线稳健

源码属性: 不加密
公式类型: 副图公式
适用软件: 通达信
未来函数: 未知
适合环境: 不限

指标公式描述

图片:

指标:

MACD2:=2*(MACD.DIF-MACD.DEA);

STICKLINE(MACD2>=0 AND MACD2>REF(MACD2,1),0,MACD2,1.2,0),COLOR0000A5;

STICKLINE(MACD2>=0 AND MACD2<REF(MACD2,1),0,MACD2,1.2,0),COLORAA7800;

STICKLINE(MACD2<0 AND MACD2<REF(MACD2,1),0,MACD2,1.2,0),COLOR00A500;

STICKLINE(MACD2<0 AND MACD2>REF(MACD2,1),0,MACD2,1.2,0),COLORA500A5;

DIF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIF,9);

MACD:(DIF-DEA)*2,NODRAW;

JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

DRAWTEXT(二次金叉,DEA*1.25,'零下二金'),COLORWHITE;

A1:=BARSLAST(REF(CROSS(DIF,DEA),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,DEA);

DRAWTEXT(底背离,DIF*0.5,'日底背'),COLORRED;

A2:=BARSLAST(REF(CROSS(DEA,DIF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(DEA,DIF);

DRAWTEXT(顶背离,DIF*1.12,'日顶背'),COLORGREEN;

RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9));

K:=SMA(RSV,9,3),NODRAW;

D:=SMA(K,9,3),NODRAW;

J:=3*K-2*D,NODRAW;

M&K金共:=CROSS(DIF,DEA) AND CROSS(K,D) AND CROSS(J,D);

DRAWTEXT(M&K金共,DEA*1.12,'金叉共振'),COLORYELLOW;

MACD高:=HHV(MACD,5);

C1:=BARSLAST(REF(CROSS(DEA,DIF),1));

E:=REF(C,C1+1)>C AND DEA>0 AND REF(MACD高,C1+1)<MACD高 AND CROSS(DEA,DIF) ;

DRAWTEXT(E>0,-0.5,'柱顶背'),COLORCYAN;

F:=REF(C,A1+1)>C AND DEA<0 AND REF(MACD高,A1+1)<MACD高 AND CROSS(DIF,DEA);

DRAWTEXT(F>0,0.5,'柱底背'),COLORLIRED;

JC:= DEA-DIF;

绿柱面积:=IF(MACD<0,SUM(MACD,BARSLAST(JC<0)),0);

红柱面积:=IF(MACD>0,SUM(MACD,BARSLAST(JC>0)),0);

本次最低价:=LLV(L,BARSLAST(JC<0));

本次最高价:=HHV(H,BARSLAST(JC>0));

X1:=IF (MACD<0,BARSLAST(CROSS(DIF,DEA)),0);

前次绿柱面积:=REF(绿柱面积,X1+1);

前次最低价:=REF(本次最低价,X1+1);

Y1:=IF((绿柱面积<0 AND ABS(绿柱面积)<ABS(前次绿柱面积) AND 本次最低价<前次最低价 ),1,0);

RS1:= MACD<0 AND REF(MACD,1)<0 AND C<前次最低价

AND ABS(绿柱面积)<ABS(前次绿柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

底背驰:= IF (CROSS(DIF,DEA),REF(Y1,1),0);

DRAWTEXT(底背驰,DEA*0.8,'积底背'),COLORFF80FF;

X2:=IF (MACD>0,BARSLAST(CROSS(DEA,DIF)),0);

前次红柱面积:=REF(红柱面积,X2+1);

前次最高价:=REF(本次最高价,X2+1);

Y2:=IF((红柱面积>0 AND 红柱面积<前次红柱面积 AND 本次最高价>前次最高价 ),1,0);

RS2:= MACD>0 AND REF(MACD,1)>0 AND C>前次最高价 AND ABS(红柱面积)<ABS(前次红柱面积) AND ABS(MACD)<ABS(REF(MACD,1));

顶背驰:= IF (CROSS(DEA,DIF),REF(Y2,1),0);

DRAWTEXT(顶背驰,DEA*0.8,'积顶背'),COLORCYAN;

其他说明
1、下载本公式需要消耗财富币,请保证你的财富币充足哦! 去充值

2、如果您发现网站有不足之处,请点击  建议反馈  谢谢!

3、如果您发现下载的公式有违规操作,请点击  举报投诉  谢谢!

公式下载需要5财富币
该指标不需要下载,请直接复制上面指标代码内容导入炒股软件即可

下一篇: 通达信最佳趋势顶底指标用透跟随主力便盈利了,异动及时布局选股公式,无未来源码

上一篇: 红桥波段转强信号主图公式源码

评论

150

  • 公式评论(0)

技巧来源

XiaoHe

 已认证

联系QQ:1379940967

联系邮箱:1379940967@qq.com

发布作品:

公式622 文章512 粉丝数59

该专家发布的其他公式

更多

同类公式

成为炒股高手